Semi Protection

UESPWiki:Administrator Noticeboard/Archive 37

The UESPWiki – Your source for The Elder Scrolls since 1995
Jump to: navigation, search
This is an archive of past UESPWiki:Administrator Noticeboard discussions. Do not edit the contents of this page, except for maintenance such as updating links.

Move over Redirect

Hey there, a quick request for a move over redirect please, for ON:The Lightless Oubliette (place)ON:The Lightless Oubliette and ON:The Black Forge (place)ON:The Black Forge. This is in line with the discussion on disambiguation importance from September 2014. I've moved the book page out of the name, but due to the page already existing, I can't move the place page in. Thanks! --Enodoc (talk) 14:18, 6 March 2015 (GMT)

Done. —Legoless (talk) 15:03, 6 March 2015 (GMT)
Another please, for ON:The Bastard's Tomb (place)ON:The Bastard's Tomb. Thanks! --Enodoc (talk) 20:43, 29 April 2015 (GMT)
Yes☑ Done. Jeancey (talk) 20:54, 29 April 2015 (GMT)
And another, por favor. ON:Drublog ClanON:Drublog. "Clan" is not part of the faction's name, so shouldn't be there. I thought I could do this myself, but since the redirect has a history that doesn't work. --Enodoc (talk) 21:46, 18 October 2015 (UTC)
Done. —Legoless (talk) 21:50, 18 October 2015 (UTC)

Warning Required?

Does Minor Edits deserve an official warning for what he said about an IP? DRAGON GUARD(TALK) 19:22, 4 October 2015 (UTC)

While the language is less than ideal, considering what the IP did, I think it's not an unfair characterization. So, I'd say no on the official warning, but I can understand your concern. Robin Hood  (talk) 21:02, 4 October 2015 (UTC)
So "it's not an unfair characterization"? The language could have resulted in an all-out war and provoked the IP. I still lay the blame with Minor Edits. The site will not benefit from name-calling. Show of hands - do we want name-callers or friendly editors? Being confrontational is not the way to approach someone on the wiki, even if they are adding "nonsense or obscenities"', advertising guilds on "the official guild page", or clearing out the guild bank in ESO. If it was because of the guild bank issue, it was completely unnecessary to bring it up on the wiki. I know how actions can have consequences, but sometimes the consequences are not always bad ones. The "good" consequence here may be that he won't get a warning/block, and we won't lose a very valuable editor. What do you think? DRAGON GUARD(TALK) 21:27, 4 October 2015 (UTC)
You asked if a warning was called for and I gave you my opinion. Asking for a show of hands is a form of forum-shopping. If anyone has objections to what I said, I'm sure they'd say so without your asking the same question a second time, hoping for a different answer from someone else. As for an all out war, that's rather unlikely. The IP demonstrated bad faith in stealing from the guild bank; it's not undue for that information to be posted to the wiki so that guild members and guild leaders are aware of the issue. Robin Hood  (talk) 03:28, 5 October 2015 (UTC)
I don't intend to give ME a warning over this. --AKB Talk Cont Mail 03:53, 5 October 2015 (UTC)
So Minor Edits used the language he did because he was provoked? Is it still breaking the etiquette policy or will it be overlooked? Put it this way - we don't want it to become a habit. As for the "guild bank", I don't play ESO, thus am not familiar with them. DRAGON GUARD(TALK) 07:08, 5 October 2015 (UTC)
Put simply, nobody's perfect—minor, infrequent infractions can be overlooked as long as the person is otherwise in good standing. As for the term "guild bank", while I don't play ESO either, I understand that it's a shared resource where people who are playing for a specific guild (aka, team) can deposit money or goods that they may not need, while people from the same guild who do need them can then take those items or money. This process can be abused and people will sometimes join a guild for the sole purpose of taking as much as they can, while not giving anything back. That's my understanding of what's going on, but as I say, I don't play ESO, so if I've gotten anything wrong here, anyone who does play ESO please correct me. Robin Hood  (talk) 07:29, 5 October 2015 (UTC)
Yep, that's essentially the way it works. Anyone who is a contributor here is invited to join our in-game guild for chatting, playing together, trading, and sharing resources. The Guild Bank is the medium for sharing resources, and can have up to 500 item stacks in it. It seems the IP has taken everything from the Guild Bank without exchanging it for something else, and then quit the Guild. Essentially, they have stolen all the items that were there and there's no way to get them back. Similar things have happened before on PC EU and we adjusted the rank system to address it. --Enodoc (talk) 12:30, 5 October 2015 (UTC)

() Well, I'll give an official apology, at least. I'm sorry for the unnecessary agitation. I was tired, upset, and rather ill when I wrote that. I regretted it immediately. It won't happen again. Insignificant RevisionsThreatsEvidence 14:08, 5 October 2015 (UTC)

Your apology is accepted. DRAGON GUARD(TALK) 16:17, 5 October 2015 (UTC)
While the language is unprofessional, I know all too well what it's like dealing with guild thieves, and how frustrating it can be. In Minor's defense, that guy didn't seem too bothered by it, judging by his response (in fact, he seemed like a textbook troll). While profanity directed at other people should be avoided on the wiki, I can't say the guy wasn't deserving of some choice words.
On a side note, is there some way to restrict access to the guild bank among members? I don't play ESO myself, but I know in WoW you can set it up so only members of a certain rank can withdraw items, and access to guild funds is usually restricting to Officers/Lieutenants/Whatever they're called. If similar restrictions are available in ESO, this kind of thing might be prevented in the future. Zul do onikaanLaan tinvaak 21:00, 5 October 2015 (UTC)
Yep, that's what we did on PC EU after the third bank heist. —Legoless (talk) 21:15, 5 October 2015 (UTC)

Can I change my name?

I fat fingered my name, I would like a new one.

Can I have Kelvar, rather than Kelar? — Unsigned comment by Kelar (talkcontribs) at 04:36 on October 5, 2015

The wiki software allows us to move you from one user to another, but that would actually be more effort, and still leave the name Kelar in use (sort of), so it's easiest if you just create the new account and forget about this one. Generally speaking, we only move accounts if they have a number of edits to their name, or something else significant in their history, like official warnings or elevated rights. Robin Hood  (talk) 05:27, 5 October 2015 (UTC)

ESO:Orsinium DLC

The ESO:Orsinium DLC is available on the PTS server and I've done a bit of pre-release data mining for those interested.

If you are looking for specific data/files let me know. -- Daveh (talk) 14:03, 7 October 2015 (UTC)

Thanks for these! Having an explore through them now. --Enodoc (talk) 19:43, 7 October 2015 (UTC)
I've updated the ESO Maps with 100 or so new/updated maps and will be updating them with locations/links over the next few days. -- Daveh (talk) 14:45, 8 October 2015 (UTC)
While we're at it, could the "Mundus" map be renamed to "The Aurbis", as it appears in-game? I changed the displayed name but it still shows as "Mundus" on the list. Plus, the new zone's name is Wrothgar, not Orsinium. --Vordur Steel-Hammer (TINV1K) 19:52, 8 October 2015 (UTC)
Do a reload of the map and your world name change should update (seems to be a display bug). I'll be updating the Orsinium maps today hopefully and will fix locations to match their in-game name. -- Daveh (talk) 12:17, 9 October 2015 (UTC)
Hey Dave, according to maps.diff there are 9 changed maps in addition to the 70+ new maps. Would you be able to upload those as well? Thanks! --Enodoc (talk) 18:27, 14 October 2015 (UTC)
Done! Added to the same maps zip file above. -- Daveh (talk) 21:09, 14 October 2015 (UTC)

AKB Leaving

Hey, I'm going to not be in a position to do anything for the UESP for quite a while. While I'll return someday, some rights need to be passed off:

  • IRC ownership (Robin's a current owner, but we need an active admin or patroller in there)
  • Social media management (I've ended up as the only user who has updated most of them in quite a while, someone else needs to do this)

We need volunteers for this, please. --AKB Talk Cont Mail 04:16, 12 October 2015 (UTC)

Oh no! It's going to be really lonely around here without you, and I'm sure the wiki won't run quite as well, but I understand that we all have our own obligations. I hope things go alright with you, and I can't wait to see you return! Zul do onikaanLaan tinvaak 22:28, 12 October 2015 (UTC)
Sorry to hear that, but I know how it goes. Hope to see you back soon. I would love to help out however I can, but I'm in a similar position, with pretty limited free time. Insignificant RevisionsThreatsEvidence 19:35, 13 October 2015 (UTC)

Unused Faction-Rank Categories

Since I've been working with our {{Faction}} template lately, I'm noticing that our Unused Categories have a lot of faction-rank categories that are empty. It could be argued that they nevertheless serve a purpose, in that you can click Next/Previous to iterate through each rank, but I think that information is better found on the relevant faction pages themselves. Is there any reason I shouldn't delete the empty categories and then, where necessary, re-link appropriately (e.g., Category:Bloodmoon-Factions-East Empire Company-StewardCategory:Bloodmoon-Factions-East Empire Company-Negotiator)? Since unused categories qualify for speedy deletion, I thought I'd ask before I just go ahead and delete them en masse. Robin Hood  (talk) 21:11, 20 October 2015 (UTC)

I'm not really sure why those faction categories even have a navbar. If it's empty, delete it. —Legoless (talk) 13:37, 21 October 2015 (UTC)
I got busy on another project today, but I'll go ahead and do that tomorrow then. Robin Hood  (talk) 07:45, 22 October 2015 (UTC)
Okay, I've cleaned that whole list up a fair bit. I've left a few Online ones, since I know nothing about them, so someone with ESO experience will have to decide if they should be deleted or what should happen to them. I've similarly left a whole bunch of Tamriel Rebuilt factions under the assumption that they'll be populated later on as well. Robin Hood  (talk) 22:36, 24 October 2015 (UTC)

Bruma on Skyrim's map

It has already been brougth up twice, so I figured I'd post it here: There's a falsely placed Bruma on our Skyrim map. -- SarthesArai Talk 13:11, 7 November 2015 (UTC)

Well, that's just bizarre! That was actually supposed to be the side door to Dead Crone Rock but it had been updated with all of Bruma's data from the Oblivion map. There's no way to know whether that was a system glitch or if one of the Cartographers somehow massively changed it, or a combination of both (i.e., one of the Cartographers changing it but a system glitch updating it with the wrong data). One way or another, though, it's back where it belongs now, with the correct data for name, marker icon, etc. Robin Hood  (talk) 22:13, 7 November 2015 (UTC)

ESO:Orsinium DLC Release

Now that the ESO:Orsinium DLC is out I've uploaded the full dumps of various image/data files again:

I've updated the map tiles and item icons already and am working on updating the items/skills database. If you are looking data/files in particular from Orsinium let me know. -- Daveh (talk) 19:16, 10 November 2015 (UTC)

Hey Dave, thanks for these. Just wondering whether the diffs are diffs from the Orsinium PTS upload or diffs from the previous Live upload (Imperial City). Thanks! --Enodoc (talk) 23:26, 10 November 2015 (UTC)
Oh, the diffs are from the last major update (1.7, Imperial City). If you need diffs from the PTS upload I did let me know (there don't seem to be too many changes at a glance). -- Daveh (talk) 02:43, 11 November 2015 (UTC)
I've updated the raw data items/sets on Note that I've only updated "new" items (items with ID >= 64468) to save a few days of mining time. If you notice any item that has incorrect stats let me know. I'll update all the "old" items as time permits in the next few weeks. -- Daveh (talk) 00:48, 12 November 2015 (UTC)

Search box has mysteriously lost most of its Oblivion and Skyrim Entries

Discussion moved from UESPWiki:Community Portal

Once upon a time I could use the UESP wiki's search box for just about everything. Now, recently, for no real reason, most of the entries are not entered into the search box for common locations. Example: "Skyrim: Valtheim Towers" needs you to type in this exact name and pres enter to find it (it will not give you the popup), instead of typing 'valtheim' to get it to appear below the box automatically. Also, "Halldir's Cairn" is difficult to find the page for. Unless you type in the exact "Skyrim: Halldir's Cairn" you need to go through another page just to find a link to it. Typing halldir's cairn into search also does not give you the right page; the first search option it gives is the talk page, every time. I went through Oblivion and it was even worse. I'm guessing this might have something to do with how often people search for these particular things; that's why I keep getting Online entries instead of Oblivion entries sometimes. But this doesn't explain why locations unique to Oblivion or Skyrim wouldn't appear when I search for them. Why is this happening? I haven't done any advanced options to get rid of Skyrim or Oblivion entries. I have tried to remove the Online entries from my search, but it is still difficult to find quick links to locations. Does anyone have an idea of what I can do about this? — Unsigned comment by (talk) at 03:13 on 17 November 2015

I've also esperienced similar issues; the search box "knows" only a fraction of the sites, and the search results more often include talk pages, archives and pages that link to the search's destination rather than that site itself. I think started happening as we switched to that new searching engine. I don't know if it is something that will rectify if we give it more time, or if there is something we can fix about it -- SarthesArai Talk 20:10, 17 November 2015 (UTC)
Yes, I've noticed a lot of missing entries as well. Dave's looked at this more than I have, I think, but my primitive understanding is that there are some incompatibilities between CirrusSearch (which is what powers the search box from our point of view) and early versions of ElasticSearch (which is what powers the database side of the search). We're using an early version of ElasticSearch because later versions aren't compatible with MediaWiki 1.22. I believe at this point, our only "fix" is to upgrade the entire wiki to 1.25+ and upgrade all the search-related stuff along with it. Obviously, that's not a quick and easy fix. I don't know if rebuilding the search index would help, but I'll send Dave an e-mail and direct him to this discussion. Robin Hood  (talk) 20:40, 17 November 2015 (UTC)
This seems to be the same issue as brought up before due to the new search index we switched to a few months back. Since we're running MediaWiki v1.22 we're using basically the first version of the CirrusSearch extension which may be at least part of the issue. Unfortunately, v1.23 or later of CirrusSearch does not work with MW v1.22 so it will require a full upgrade. I'll look into starting the upgrade process to v1.23 this week. There is little I can do now, unfortunately, as the v1.22 of CirrusSearch lacks most of the debugging options in later releases. Once we're running v1.23 I can take another look and see if the problem still persists or hopefully the root of the issue if it still does. Part of the issue may be our "unique" namespace arrangement which we may need to tweak the search index to work with.
As an example of the current issue for future reference. If we search for "Farkas" the results are:
  • Skyrim talk:Farkas
  • Skyrim:Farkas's Wolf Spirit (the only result when typing in the search box)
  • ...
Note that the obvious result of "Skyrim:Farkas" isn't returned even though its talk page is. Searching for "Skyrim Farkas" returns similar results and omits the obvious page. Only an explicit search for "Skyrim:Farkas" gives you the exact page as a result. There are similar issues with subpages returning as a result but not the root article (e.g., "upgrade history"). If anyone has other good example of searches not working as expected you can list them here and we'll test them after the upgrade. -- Daveh (talk) 18:02, 18 November 2015 (UTC)
Thanks for investigating this. Try searching "Weapons". Most other namespaces work. Might be some unnoticed difference in namespace settings or search settings. OOTB version of wikimedia allows selecting which namespaces to search by default (user preferences). And defaults can be configured in admin settings. I am not familiar with your advanced search add-ins, though I would imagine they have similar settings. Apologies if I am stating the obvious... :). Good luck, looking forward to this working again! Zojj (talk) 04:42, 25 November 2015 (UTC)

() Fixed -- Upgrading to MediaWiki v1.23, reindexing the site, and fixing the hardcoded list of namespaces for the prefix search seems to have fixed all the issues noted here. If any other issue pops up, now or later, let me know. -- Daveh (talk) 18:08, 27 November 2015 (UTC)

Wiki Upgrade v1.23

I've updated the Dev Wiki to MediaWiki v1.23 in preparation of upgrading the main wiki in the near future. Surprisingly, everything seems to be working fine but I'll be testing it more next week to see if anything needs fixing before starting the upgrade here. Note that search is not working on the dev wiki but that is due to a difference in database names (as far as I can tell). If you find anything on dev that is broken just let me know. -- Daveh (talk) 14:47, 20 November 2015 (UTC)

The "Your edit was saved." pop-up is appearing every time I load a page I have edited. I believe this used to be an issue and was fixed later, but it's happening again, at least for me. ~ Dwarfmp (talk) 12:35, 22 November 2015 (UTC)
I don't remember fixing this myself but will see if I can figure out what happened last time. -- Daveh (talk) 17:22, 24 November 2015 (UTC)

Upgrade Notice -- 26 Nov 2015 (Thursday Morning) -- Since there appears to be no significant issues running v1.23 I'd like to do the upgrade this Thursday morning. There should be no downtime and a minimal amount of the Wiki being set to read-only. I'll update this section with the upgrade progress when it happens. -- Daveh (talk) 17:22, 24 November 2015 (UTC)

Search Broken -- It seems that something breaks the Elastic search in update v1.23. The simplest thing will be to recreate the search indexes after the upgrade which means search will be not working (or not 100% working) for a few hours after the upgrade. -- Daveh (talk) 18:30, 24 November 2015 (UTC)
Upgrade Started -- Read Only -- The wiki will be shortly set to read-only in preparation for the upgrade to MW v1.23. Expected time is 1-3 hours. -- Daveh (talk) 13:11, 26 November 2015 (UTC)
Upgrade Finished -- The upgrade to MediaWiki v1.23 is now finished and read-only mode has been turned off. There were a few issues during the upgrade including a brief outage (caused by a typo in a database name) and having to restart memcached (everyone will have to login again). Hopefully those are the only major issues but if you notice anything post it below. -- Daveh (talk) 15:11, 26 November 2015 (UTC)

Upgrade Issues

  • Search -- The search is currently not working (as expected) and I'll be reindexing everything over the next few hours to get it up ASAP. -- Daveh (talk) 15:12, 26 November 2015 (UTC)
The site has been re-indexed and search is back to working (sort of). The search results are better than last time and don't seem to show the lack of "obvious" results. The popup search results only work if you enter the namespace prefix. So "vampire" doesn't show anything but "skyrim:vampire" or "sr:vampire" do. We'll likely have to modify the search engine to work with our custom namespace usage and I'll start looking at that right away. Meanwhile, feel free to let me know of any new/old search oddities or issues. -- Daveh (talk) 23:20, 26 November 2015 (UTC)
Prefix search was fixed by including a hard-coded list of namespaces in a JS file that I had forgotten about from last time. It appears to be working now (a full page reload is needed) and all of the past issues regarding search don't seem to appear anymore. -- Daveh (talk) 18:06, 27 November 2015 (UTC)
  • Recent Changes Issue
I think this is realted to the current update process, but I post it here regardless. Everytime I try to refresh the Recent Changes, I get a message saying
Sorry! This site is experiencing technical difficulties. Try waiting a few minutes and reloading. (Cannot contact the database server)
A hard refresh (ctrl + F5) works fine. Additionally, the page says "Show new changes starting from $2, $3" -- SarthesArai Talk 20:15, 26 November 2015 (UTC)
Yes, this is definitely something related to the upgrade. It seems to work fine when logged in (at least for me) but viewing anonymously returns an error code. Purging the page works once but the same error appears on subsequent loads. Looking into now. -- Daveh (talk) 20:19, 26 November 2015 (UTC)
Can anyone duplicate this? Everything works fine on Chrome or with a direct curl request but IE/Edge/Firefox on Windows 10 results in the Special:RecentChanges erroring out on load. On FireFox it works if I do a hard reload (Shift+F5) but not on IE. It seems to be a Squid related issue as a direct request to content1/2/3 works fine. I seem to recall an almost identical issue but cannot find any record of what was done to fix it (or even when it was). -- Daveh (talk) 20:39, 26 November 2015 (UTC)
Fixed this for now with an explicit Squid rule to not cache Special:RecentChanges. The prior issue we had was with Special:SpecialPages. I'm unsure why there was a variation between getting the page in different browsers. -- Daveh (talk) 21:16, 26 November 2015 (UTC)
One issue still remains. It still says"Show new changes starting from $2, $3 ". MetaCthulhu reported that, too. -- SarthesArai Talk 19:24, 1 December 2015 (UTC)

() Oops, forgot about this one. Let me look into it and see. Probably just a default message we have to change. -- Daveh (talk) 01:59, 2 December 2015 (UTC)

Should be fixed now. The rclistfrom message format changed so I had to update the code in our UespCustomCode extension to match the change in MW. -- Daveh (talk) 02:36, 2 December 2015 (UTC)
Everything looks good on my end. Thank you! --MetaCthulhu (talk) 03:11, 2 December 2015 (UTC)
  • E-mail on page edit (very minor)
I'm not sure if this was an option that got changed or one that was failing under 1.22 and just started working again, but all of a sudden, I'm getting e-mails whenever a watched page changes, where I didn't used to. This might be related to the Hotmail/Live issues, but I don't think so because I usually got notifications of my user talk page being changed before, just not other page changes. Either way, the setting was turned on in my options, so I just turned it off to fix it. Robin Hood  (talk) 20:29, 26 November 2015 (UTC)
I got notifications on this page edit but used to only get notifications when my talk page was changed. Looking at the patch notes I think this is the reason:

Preferences 'watchcreations', 'watchdefault', 'enotifwatchlistpages' ("Add pages I create and files I upload to my watchlist", "Add pages and files I edit to my watchlist", "Email me when a page or file on my watchlist is changed") are now enabled by default. In addition new user accounts' personal and talk pages are now watched by them by default.

I'm assuming it changed for everyone. -- Daveh (talk) 20:43, 26 November 2015 (UTC)
Changed for me as well (with 7,671 pages watched - luckily it's been a slow day!), but I switched back the preferences. —Legoless (talk) 22:22, 26 November 2015 (UTC)
  • Special:Patrol
It seems this page is broken as well, I only get a white screen. -- SarthesArai Talk 16:58, 27 November 2015 (UTC)
Fixed -- Was an issue with that plugin using a removed function along with a Squid cache issue (it kept returning the error page). Both fixed and it should load fine for everyone now. -- Daveh (talk) 18:27, 27 November 2015 (UTC)
  • Watchlists
For some reason, editing pages adds them to my watchlist after the edit is saved...possibly related to the email on page edit issue above? Zul do onikaanLaan tinvaak 20:51, 1 December 2015 (UTC)
I assume this is due to a new setting (or a new default) of Add pages and files I edit to my watchlist in your Watchlist section of preferences. Just set that to off if you wish. -- Daveh (talk) 21:51, 1 December 2015 (UTC)

Corrupted Image

What happened here? Seems we lost the October 2011 version of this image. —Legoless (talk) 00:19, 22 November 2015 (UTC)

I have the file saved (I should even have all unedited screenshots of every shot I ever uploaded), so I can re-upload it if this is necessary. But it would be nice to know the cause indeed. ~ Dwarfmp (talk) 12:31, 22 November 2015 (UTC)
Well, that's good at least. I managed to save the cached 600px version anyway, but if the same happened on a less reproducible file we'd be in trouble. —Legoless (talk) 18:38, 22 November 2015 (UTC)
There was a minor problem in the database, probably from some obscure bug or something. I've fixed the issue and restored the image. Robin Hood  (talk) 04:01, 23 November 2015 (UTC)

Thumbnail Icon

Can we remove this icon from our thumbnail borders, or at least toggle it off? This was brought up a couple years ago and I believe consensus was established at the time, but nothing was ever done. —Legoless (talk) 16:38, 28 November 2015 (UTC)

I don't remember the discussion, but it's easy enough to do (see the last entry in my CSS page). We'd just need to add that to Common.css as long as nobody objects (or if there's only a small minority, they can override the setting in their own CSS file with div.magnify { display:block; }). Robin Hood  (talk) 17:42, 28 November 2015 (UTC)
I'm struggling to find it (think it was pre-Skyrim), so some input from current editors would certainly be warranted. —Legoless (talk) 18:01, 28 November 2015 (UTC)

Translation Projects

The subject of translation projects for the UESP comes up from time to time and I'd thought a little discussion on the matter would be good. There are basically two options unless someone can think of any more:

  1. Self-Hosted -- We host the translation projects on our servers.
  2. Independent -- Someone else hosts the translation wiki and is completely separate from this site.

My preference is for #1 as we can easily re-use all the images, user logins, templates, extensions, servers, etc.... The downside is the increased maintenance required on all aspects (server admin, wiki admin, wiki content). An independently hosted translation is the easiest from our end as someone else is doing all the work but I'm not sure I feel comfortable letting Internet strangers run an associated UESP site by themselves.

I'm leaning on looking into getting #1 setup but wanted feedback from admins and editors as it potentially means a little more work from everyone. The other big question is which translations would be useful to have, or more importantly, which translations have users that can actively manage them. I'll look into the details of how a translation MediaWiki is setup over the holidays to make sure I understand exactly what is involved and how it will fit into our infrastructure. Happy Holidays! -- Daveh (talk) 14:49, 22 December 2015 (UTC)

I think the first thing we need to do is determine if there's a sufficient interest from our readerbase to justify such a large undertaking. We're already stretched a bit more thin than in previous years maintaining the English version of the site, and since most of our users (I assume) are more comfortable with English, I feel like a translated version of the site would inevitably end up having less attention paid to it maintenance-wise. If there are a relatively large number of people who would prefer to read the site in another language, it may be worth trying, but if it's a concept that only appeals to a few people, I can't see the extra effort involved in maintenance being worth the outcome.
If we do end up doing this, I agree that it's preferable to keep it internal if it's going to have our names attached to it. As for which translations we should have, we may want to do a trial run with just one of the more common languages (like Spanish or French). That way we can judge the logistics of translating our articles and maintaining them. If it works out alright, we could poll for opinions on the social media pages as to which other languages we can translate to.
However, I think it would be wise not to set our expectations too high for versions of the site translated into more than a few languages, if that. A site the size of Wikipedia may be able to get away with that, but our relatively small userbase means that it's unlikely we'll ever have enough manpower to accurately monitor the quality of articles in 12 different languages. Zul do onikaanLaan tinvaak 22:28, 22 December 2015 (UTC)
Sup, i'm the crazy one who's trying to translate the UESP to portuguese. I've been making lore texts in portugues for the last 2 years, basing on UESP's texts, and giving the deserved credits, obviously. The brazilian TES fanbase is NOT big. There's like, only 5.000 people who are really interested in the TES games, so making a "UESP-BR" its a hard step, but you know, those few people give me a lot of support and one of the reasons why the brazilian fandom is small may be because there aren't many documents in portuguese, but I believe that giving them lore, giving them something worth reading, might increase the numbers fiercely. So, i thought: "I should make a site where i can save all my translations, but i should translate the quests too, so why not translate the UESP, right?" Then i contacted Dave, to see if that is possible.
Both possibilities are ok by me, i would be more comfortable if i could host it, but why not try the first option, creating a subdomain shouldn't be that hard. And you know, in the first months i will only translate Lore and Rules pages, and if the project succeeds, I might create forum, and this kind of stuff. Anyway, thank you guys. --Jörmungandr (talk) 01:09, 23 December 2015 (UTC)
I don't think a self-hosted translation project should be associated with UESP, especially since the licence on our content allows for copying as long as credit is given. If we decide to host alternate language wikis, I think editing rights should be more tightly restricted (e.g. no anonymous editing, non-confirmed users needing manual approval to edit, etc.) to limit vandalism. If there won't be many editors, that means there won't be many patrollers either, and our current staff simply wouldn't be able to maintain both even if language proficiency wasn't an issue. It's also worth considering policy - would these new wikis be subject to our current guidelines and standards, or would they be allowed to change it based on (probably rather limited) consensus? —Legoless (talk) 14:30, 24 December 2015 (UTC)

() Some good, if few, comments here. I looked at the options for setting up a multi-language wiki and there seems to be two ways to do it:

  1. Multi-language on one wiki
  2. Multiple wikis each with their own language

I was hoping to use #1 as it would make a lot of things simpler but it seems to be extremely complex to setup and use. #2 is more work to setup and get going but seems to be the best option for us at the moment. What I'd like to do is setup a wiki for translation into Portuguese and use that as a test to see how it goes. I very much expect it to be a "work in progress" and hope that Jörmungandr takes a lead in the project, especially given my lack of Portuguese at the moment. -- Daveh (talk) 21:12, 18 January 2016 (UTC)

The Portuguese translation wiki should now be in a usable state at I very much expect this to just be the start of the translation administration work as we figure out how best to run and connect it to the main wiki. How this project goes will determine the future of any other translation wikis.
  • I've chosen Portuguese as the language but just noticed Jörmungandr mention Brazil. Is there a difference and if you prefer the new translation wiki to be in Brazilian Portuguese let me know. This changes the language code from pt to pt-br but it would be better to change it now rather than later.
  • User names/preferences are shared between wikis so use the same login.
  • Images are shared with the main wiki.
  • I've turned off anonymous edits on the translation wiki and added the Translator user-group which is admin-like for the translating "owners" of the wiki (Jörmungandr in this case). The user-groups between the main and translation wiki are separate so we can fine tune permissions as needed.
  • I've imported the Template and MediaWiki namespaces to the new wiki.
  • Added the interwiki links of en and pt.
I'm suggesting that further discussion this translation project be done on the Translations talk page. -- Daveh (talk) 15:38, 21 January 2016 (UTC)

Template categories error

I'm currently getting a MWException error any time I try to access any of the sub-categories in Templates. It looks like:

[cc621ebc] 2016-01-03 15:52:25: Fatal exception of type MWException

The hexcode changes every time, so not sure that's useful. Not sure what could be causing this, but someone should probably look into it. — TheRealLurlock (talk) 15:53, 3 January 2016 (UTC)

Getting the same thing. —Legoless (talk) 16:49, 3 January 2016 (UTC)
(Mostly for Dave) I can replicate the problem on the development server, so I'm looking at it there now. I'll update this if/when I fix the problem. (Update: on hold due to permissions problem.) Robin Hood  (talk) 18:45, 3 January 2016 (UTC)
This is now fixed. You may have to do a purge or hard refresh, it varied for me in testing. Robin Hood  (talk) 20:09, 6 January 2016 (UTC)

() Looks like Category:Marked for Deletion is broken as well. It shows the bullets for each page, but the actual links aren't there. —Legoless (talk) 17:55, 16 January 2016 (UTC)

What, you didn't want to just guess what to delete? :Þ I think I've fixed it now, but I'm not entirely sure why it was done the way it was, and I took the more direct approach to it. Hopefully I haven't broken anything else in the process. I poked around other categories, and everything looks fine, but only categories with <catpagetemplate> tags should be affected, which aren't easy to track down. Robin Hood  (talk) 23:21, 16 January 2016 (UTC)

Corrupted Image, Round 2

I've been trying to upload a quest image for the quest Whose Wedding?, but the actual file just throws an error at me -- SarthesArai Talk 19:55, 20 January 2016 (UTC)

I wouldn't be surprised if something isn't correctly handling the question mark, because the file it's complaining isn't there actually is. Try uploading it again without the question mark and I'll delete that page. Robin Hood  (talk) 22:55, 20 January 2016 (UTC)
That was my guess too, although it appears to be escaping the ? correctly in the error code. The image file in question exists and seems fine. -- Daveh (talk) 01:02, 21 January 2016 (UTC)

Showhide on Mobile Skin

Hey there! How's everyone's javascripting? I have no idea what needs to be done to address it, but the {{Showhide}} template doesn't work in the Mobile View. A good example of this (due to its extensive use of the template) is Online Repeatable Quests, where none of the Quest Lists can be opened. Thanks! --Enodoc (talk) 15:00, 26 January 2016 (UTC)

For anyone who clicked on the Online Repeatable Quests link and is now looking for how to get back out of mobile mode, click here.
Enodoc: Well, overall, our javascript is weak on this site. Of the active editors, I believe Dave is proficient, and I just kind of poke at it with a stick until it works. My first question, though, is: does Javascript even run in mobile mode? I just looked at Help:Tables, which uses Javascript for collapsible tables, and that also doesn't seem to be working. Since I'm the only person on the planet without an honest-to-goodness mobile phone, I'm not used to using our mobile site, so I don't know if JS is supposed to work there or not. Robin Hood  (talk) 20:15, 26 January 2016 (UTC) looks like the HTML for the "show" button just doesn't exist on the mobile version but I have no idea why. Looking into it further and will let you know if I figure out anything.
JavaScript should be working on the mobile site. It might be related to having the mobile skin not being "uespmonobook" but I don't think we have much hard coded for that skin. -- Daveh (talk) 20:18, 26 January 2016 (UTC)
So the problem was just that the MobileFrontEnd extension doesn't use the MediaWiki:Common.css and MediaWiki:Common.js files but instead uses MediaWiki:Mobile.css and MediaWiki:Mobile.js, something that is not immediately obvious from any documentation of course. Just copying Common.js to Mobile.js doesn't work due to a change in the JavaScript scope (for whatever reason) but once that is fixed things seem to be working now. If anyone notices more broken JS or anything else on the mobile site just let me know. You may have to do a hard-reload in your browser for the change to show up.
Note that I haven't copied Common.css to Mobile.css as doing so breaks the mobile site horribly. If there are missing styles or tweaks needed for the mobile site we can add them by hand. -- Daveh (talk) 22:55, 27 January 2016 (UTC)
Brilliant, thanks! --Enodoc (talk) 00:18, 28 January 2016 (UTC)

ESO Thieves Guild DLC on PTS

The ESO Thieves Guild DLC is now live on the PTS (Public Test Server) and so begins the usual data extraction. Look for updates in the below list over the next few days. If you're looking for a specific file/image/information from the new DLC just let me know.

-- Daveh (talk) 01:11, 4 February 2016 (UTC)

Great! On a similar note, I've uploaded a sort of placeholder icon for the DLC but it's not particularly well-done. If anyone can find/make a better one, feel free to replace it. —Legoless (talk) 00:42, 5 February 2016 (UTC)
Thanks Dave! Nice logo, Lego; what is it? Here's my proposal: clicky. I can tone down the starburst if it would look better with less of it. --Enodoc (talk) 01:43, 5 February 2016 (UTC)
I don't actually know what it is, a rose of some kind. I put it together before I spotted that TG logo in the files, which works a lot better imo. —Legoless (talk) 01:56, 5 February 2016 (UTC)
Yeah I was very pleased to see there was a TG logo ripe for the picking. So you think the TG logo works better? Is the starburst okay as it is, or should it be toned down? --Enodoc (talk) 02:03, 5 February 2016 (UTC)
I think the starburst works fine. A little strong perhaps, but it's better than just the metallic symbol and makes it easily distinguishable as an icon. —Legoless (talk) 02:07, 5 February 2016 (UTC)
I toned down the starburst a bit and uploaded it over the rose     :)    --Enodoc (talk) 02:28, 5 February 2016 (UTC)

() That's really nice... wish I had known these resources existed when I was looking for contraband icons :p Thank you Dave for extracting all that. There's a new Thieves Guild map icon which I'm gonna upload as we speak! :) --Tib (talk) 17:16, 6 February 2016 (UTC)

Intrusive Ads

Two video ads played in successive order at the bottom of a page, one for the Concussion movie and another for Both auto-played intrusive audio. —Legoless (talk) 12:18, 11 February 2016 (UTC)

Thanks for the notice...I'll look into it. -- Daveh (talk) 15:52, 11 February 2016 (UTC)

Javascript Not Working

I just noticed today that Javascript appears to have stopped working for me. Is anyone else having this problem? If so, how long has it been going on? The last change to MediaWiki:Common.js was several weeks ago, so I don't think that would be it, but it's at least possible, so I'm looking to establish a better date for when the problems started. Robin Hood  (talk) 22:58, 19 February 2016 (UTC)

It must be. My special modified sidebar that I rely on is cluttered with all the crap I got rid of, and the stuff I want is missing. It dun broke or sumtin'! -damon  talkcontribs 23:03, 19 February 2016 (UTC)
Must have stopped working in the past 24 hours. Showhide was working for me last night. —Legoless (talk) 23:26, 19 February 2016 (UTC)
Poking around, I think the source of the problem has something to do with one of the ESO add-ons Dave's been working on. One of the Javascript files in it is reporting an error in Chrome, and when I look at that file on the server, it was modified just a few hours before my post. While I understand the general nature of the problem, I don't know how to fix it, so I've e-mailed Dave pointing him to the source of the problem. I believe it's a fairly simple fix for someone that actually knows what they're doing. :) Robin Hood  (talk) 06:40, 20 February 2016 (UTC)
I temporarily fixed the issue causing it until I can figure out a permanent fix. This was due to some new code I'm working on and didn't realize it would affect the live wiki (in theory the error in question shouldn't be happening). You might need a hard reload/refresh to update the JS files. -- Daveh (talk) 13:58, 20 February 2016 (UTC)


I think the IP has earned a block. It's been inserting nonsense into pages/created pages for nonsense, despite a warning from ThuumofReason to stop. -- SarthesArai Talk 21:17, 21 February 2016 (UTC)

Done. Looks like a nonsense bot so probably didn't even warrant an initial warning. —Legoless (talk) 21:23, 21 February 2016 (UTC)
Thanks. I figured it probably was a bot, but I wasn't a hundred percent on it, so I decided to err on the side of caution. Zul do onikaanLaan tinvaak 20:25, 23 February 2016 (UTC)
Usually for the best, just in case. The damage is probably done by then anyway. —Legoless (talk) 20:49, 23 February 2016 (UTC)

Prev: Archive 36 Up: Administrator Noticeboard Next: Archive 38