Semi Protection

UESPWiki:Administrator Noticeboard/Archives/Database Corruption

The UESPWiki – Your source for The Elder Scrolls since 1995
Jump to: navigation, search
This is an archive of past UESPWiki:Administrator Noticeboard/Archives discussions. Do not edit the contents of this page, except for maintenance such as updating links.

Database Corruption

Following the instructions "Please report this to an administrator", please see here: Oblivion:Sanguine/Description. Joram 21:43, 30 December 2009 (UTC)

It seems there has been a problem with recent deletions. Pages are showing up in some lists (eg Special:AllPages) but not others (eg the link you just provided). The bot API is also affected - trying to load OB:Garlas Agea/Description has currently been hanging RoBoT for about 5 mins. –rpehTCE 21:50, 30 December 2009 (UTC)
Thanks for pointing it out. We've not yet figured it out, but I just posted a message on Daveh's talk page here. If you see I've missed anything, feel free to chime in. --GKTalk2me 21:52, 30 December 2009 (UTC)
Two of those pages are appearing on Special:UncategorizedPages too, along with Lore Books, which I've previously mentioned to Daveh as being a problem. –rpehTCE 09:56, 31 December 2009 (UTC)
There were a few tables with the "clients are using or haven't closed the table properly" error which I have just fixed (explaining the site slowness for the past 10 minutes or so). I'm not sure if this was the cause of the issues but see if anything has changed. -- Daveh 14:45, 2 January 2010 (UTC)
Doesn't look like it - they're still showing on Special:UncategorizedPages and give the same error. We might need to wait for the job queue to catch up though. –rpehTCE 16:40, 2 January 2010 (UTC)
Looking at the raw database it appears as though there are four pages with the same issue:
All four pages have page entry but no corresponding revision record. Were these pages deleted/moved or what process was used to lose them (and was it the same one)? The previous database errors might have caused an issue with MediaWiki while it was moving/deleting the records which left the database in an inconsistent state. I can manually edit the database to fix it but want to make sure I'm doing the right thing first. -- Daveh 17:58, 2 January 2010 (UTC)
The only two I know about are the two /Description pages, which GK deleted recently (within the last 5 days or so). The other two... I have no idea. –rpehTCE 18:19, 2 January 2010 (UTC)

(u/d) We have more database problems. The WantedCategories page is showing four categories that were recently deleted as "wanted". They aren't. None of those four Description or Author categories have any pages or media in them, so it seems to be more DB corruption. The entry for "Oblivion-Place Descriptions" might be caused by the still-problematic "Oblivion:Garlas Agea/Description", but if so I'd expect to see OB-Quest Descriptions too (for "Oblivion:Sanguine/Description").

These will probably need direct hacking of the Links table to remove, which is something only Daveh can do. rpeh •TCE 11:27, 28 January 2010 (UTC)

When a page is deleted, the revisions move from the revision table to the archive table. Are the revisions for the articles in the archive table?
As for the category links, after these problematic pages have been dealt with, you can run the RefreshLinks.php maintenance script to fix the link tables. If that fails, hit it with a hammer. -- Nx / talk 00:12, 4 February 2010 (UTC)
I tried this on my home wiki by deleting the revisions of a page from the revision table, but even after that I was able to edit the page and create a new revision, fixing the problem. But on UESP I get edit conflicts no matter what I do (the last edit date is always set to the current date, since the revision doesn't exist, but that isn't triggering an edit conflict on my home wiki. It's possible the caching setup on UESP is causing this). Did anyone try deleting the four blue articles? -- Nx / talk 10:18, 4 February 2010 (UTC)
I believe GK did, without success. She should be online in a few hours and can confirm or deny then. rpeh •TCE 12:48, 4 February 2010 (UTC)
See Dave's talk page where I posted details of what I attempted. Basically, I tried to undelete two of the red-links, the two subpages shown above, and that's why they're blue links now. Should I attempt to delete them again? --GKtalk2me 21:39, 4 February 2010 (UTC)
Please do. At least if they're redlinks they won't show up on uncategorized pages and such. -- Nx / talk 21:59, 4 February 2010 (UTC)
Looks like it's worked this time... They're off Special:UncategorizedPages and Special:DeadendPages. rpeh •TCE 22:12, 4 February 2010 (UTC)
Yes, but WantedCategories still isn't empty. Oh well, guess that will have to be cleared manually. -- Nx / talk 22:17, 4 February 2010 (UTC)
Just noticed that. At least the other ones are done. Thanks for the help! rpeh •TCE 22:18, 4 February 2010 (UTC)
The categorylinks table probably has an entry with a page id that is not present in the page table. When you delete and restore a page, its entry in the page table is removed and readded with a new id, so it probably borked there. To find the offending entries:
select * from categorylinks where cl_to="Oblivion-Place Descriptions";
etc. -- Nx / talk 22:31, 4 February 2010 (UTC)

Should I undelete and redelete the remaining eight in the list on Daveh's talk page? --GKtalk2me 22:20, 4 February 2010 (UTC)

No, there's still something wrong with the database (you said you couldn't undelete when you tried, so you probably won't be able to do it now either). It doesn't really matter as long as those revisions are deleted, and the pages can be recreated. -- Nx / talk 22:31, 4 February 2010 (UTC)