Blades:System Requirements

The UESPWiki – Your source for The Elder Scrolls since 1995
Jump to: navigation, search

Supported Devices[edit]

Blades currently supports a limited number of devices, but will continue to add support to devices as the Early Access period continues.

  • Asus ZenFone 4 Pro
  • Asus ZenFone 3 Deluxe (ZS570KL)
  • Asus ZenFone AR
  • Asus ZenFone AR (ZS571KL)
  • Asus ZenFone Ares (ZS572KL)
  • Asus ZenFone V
  • BlackBerry DTEK60
  • Essential Phone
  • Google Pixel
  • Google Pixel XL
  • Google Pixel 2/2XL
  • Google Pixel 3/3XL
  • HTC U11/U11+
  • HTC U12+
  • Huawei P20/P20 Pro
  • Huawei Mate 20 Pro
  • HTC U Ultra
  • iPhone 6s and newer
  • iPhone SE
  • iPad Pro
  • iPad Mini 4 and 5
  • iPad Air 2 and 3
  • Leeco Le Max2
  • Leeco LePro3
  • LG V30
  • LG G7 One
  • LGE LG G5
  • LGE LG G6
  • LGE LG Q9
  • LGE V20
  • LGE V20 PRO
  • Motorola Moto Z
  • Moto Z2 Force
  • Moto Z3
  • Nokia 8
  • OnePlus 5 and newer
  • OnePlus OnePlus3
  • OnePlus OnePlus3T
  • OnePlus 6T
  • Razer Phone
  • Sharp Aquos R
  • Samsung Galaxy S8/S8+
  • Samsung Galaxy S9/S9+
  • Samsung Galaxy S10/S10+
  • Samsung Galaxy Note 8
  • Samsung Galaxy Note 9
  • Samsung Galaxy S7 Active
  • Sony Xperia XZ Premium
  • Sony Xperia XZs
  • Tonino Lamborghini TL99G
  • Vertex BLK3D
  • Vertu Constellation X
  • Vivo Xplay6
  • Xiaomi Mi 6
  • Xiaomi Mi Mix 2
  • Xperia XZ Premium S0-04J/G8142/G8188
  • Xperia XZ1
  • Xiaomi MI 5s Plus
  • Xiaomi Mi Note2
  • Xiaomi MIX
  • ZTE Nubia Z17
  • ZTE NX531J
  • ZTE Z999
  • ZTE A2017G
  • ZTE A2018
  • Zuk Lenovo Z2 Plus
  • Zuk Z2
  • Zuk Z2 Pro